Document creation delay

Incident Report for Root

Resolved

This incident has now been resolved.
Customers may have experienced up to one hour's delay in receiving policy and terms documents.
Posted May 13, 2025 - 14:26 SAST

Investigating

We are currently investigation the issue.
Posted May 13, 2025 - 13:44 SAST
This incident affected: API.