API Performance Degradation - Database Connection Pool Exhaustion

Incident Report for Root

Resolved

This incident has been resolved.
Posted Nov 21, 2025 - 12:40 SAST

Investigating

We are experiencing API timeouts and degraded performance due to database connection pool exhaustion.

Impact: Users may experience:
- Slow API responses
- Timeout errors on policy issuance and other operations
- Failed requests requiring retries
Posted Nov 21, 2025 - 12:22 SAST
This incident affected: API and Dashboard.